athom-api

JavaScript API client for all Athom services and products

Installation

For Node.js or compiled projects:

npm i athom-api

Alternatively:

<script type="text/javascript" src="//cdn.athom.com/athom-api/${NPM_VERSION}/athom-api.min.js"></script>

Usage

This module exports HomeyAPI and AthomCloudAPI. When used in environment without module/import support, these exports can be found at the global variable AthomAPI.

Requirements

This module runs in any environment that supports Promises and fetch, XMLHTTPRequest or request. This includes NodeJS 4 or higher, React Native, and most modern web browsers.